Ticket #17 (closed defect: wontfix)

Opened 10 years ago

Last modified 10 years ago

Python Makefile generated by configure is false

Reported by: reluc Owned by: djay
Priority: major Milestone:
Component: zoo-kernel Version: 1.0
Keywords: makefile configure Cc: reluc

Description

After doing :

  • ./configure --with-python

It's necessary to update the Makefile with doing :

  • g++ ${XML2CFLAGS} ${PYTHONCFLAGS} ${CFLAGS} -c service_internal_python.c --> g++ ${XML2CFLAGS} ${PYTHONCFLAGS} ${CFLAGS} ${PYTHON_ENABLED} -c service_internal_python.c

Change History

Changed 10 years ago by djay

  • status changed from new to closed
  • resolution set to wontfix

Hi reluc, many thanks for your feedbacks.

I'm not sure to follow the comment here. Indeed, I took twice a look at the service_internel_python.h and service_internal_python.c files and I didn't noticed any requirement for adding ${PYTHON_ENABLED} to this line.

If anything goes wrong without this flags please let us know re-opening this bug.

Waiting for your comment, I close this ticket as "wontfix" as it seems that everything is ok without this addition.

Changed 10 years ago by reluc

  • status changed from closed to reopened
  • resolution wontfix deleted

Hi djay,

The problem is not in the service_internal_python.h or in serivice_internal_python.c but in the Makefile generated by the configure.

To have Python supported, after doing :

  • ./configure --with-python

I have to update the Makefile on line 75

Changed 10 years ago by reluc

  • status changed from reopened to closed
  • resolution set to wontfix

I forgot a make clean before make zoo_loader.cgi.

Note: See TracTickets for help on using tickets.

Search

Context Navigation

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png